Major outage due to AWS incident

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:00 UTC

Identified

Due to a major incident with one of Kaleidoscope's cloud hosting providers (Heroku, hosted on AWS) we are experiencing an outage of all services.
Posted Oct 20, 2025 - 15:30 UTC
This incident affected: Marketplace, Applicant Portal, Client Portal, Review Board, and Connect.