Cannot create new applications for some programs

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Mar 01, 2025 - 07:30 UTC

Investigating

Applicants may be unable to start their application process in about 30% of cases. Root cause has been identified.
Posted Mar 01, 2025 - 05:44 UTC
This incident affected: Applicant Portal.