Some scholarships cannot accept new applications

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 21:03 UTC

Identified

Some scholarships cannot accept new applications and applicants will receive an error message.

Root cause is identified and remediation is underway.
Posted Apr 07, 2025 - 19:36 UTC
This incident affected: Marketplace.