Some platform services unavailable

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 15:13 UTC

Identified

An issue with Kaleidoscope's platform infrastructure has caused some services to temporarily become unavailable. Services are being restored.
Posted Nov 04, 2025 - 14:30 UTC
This incident affected: Applicant Portal, Client Portal, Review Board, and Connect.