Cloud provider outage impacting some functionality

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 20:31 UTC

Update

Our cloud provider is continuing recovery of affected services and expects resolution by 6PM CT.
Posted Oct 29, 2025 - 20:10 UTC

Identified

Kaleidoscope's cloud provider has identified the issue and is implementing a fix. No ETA is available for restoration of services at this time.
Posted Oct 29, 2025 - 17:26 UTC

Investigating

Some services are unavailable due to a cloud provider outage, including applying to some programs.
Posted Oct 29, 2025 - 16:16 UTC
This incident affected: Marketplace, Applicant Portal, Client Portal, Review Board, and Connect.