Reviewers cannot log in

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted May 03, 2026 - 14:02 UTC

Investigating

Reviewers cannot log in to their dashboard at this time and receive a loading icon. We are investigating this issue.
Posted May 03, 2026 - 13:18 UTC
This incident affected: Review Board.