Performance degradation in Review Board

Incident Report for Kaleidoscope

Resolved

This incident was resolved with configuration changes to the auto-scaling capability in the platform.
Posted Apr 10, 2026 - 18:00 UTC

Investigating

Due to heavy load in the review board portal, users experienced longer than usual wait times while navigating the portal and making changes to review boards.
Posted Apr 10, 2026 - 15:00 UTC
This incident affected: Review Board.