Some Kaleidoscope services unavailable

Incident Report for Kaleidoscope

Resolved

This incident has been resolved.
Posted Mar 30, 2025 - 17:24 UTC

Identified

An infrastructure issue has caused some features in the Kaleidoscope platform to become unavailable.

All reviewers and contributors are impacted by this issue, and some applicants and client users are affected. Impacted users will receive 500 errors or page timeouts.

Implementation of a fix is underway.
Posted Mar 30, 2025 - 15:30 UTC
This incident affected: Marketplace, Applicant Portal, Client Portal, Review Board, and Connect.